There are no current European directives that apply to this product.
# Table of Contents

## Preface

- Conventions .................................................. vii
- Contacting Tektronix .................................... viii

## Getting Started

### Installation Procedures

- Installing the Software ................................. 3
  - Using the Windows Program Manager ............... 3
  - Using the File Manager ............................... 4
  - Using Windows 95 ..................................... 4
- System Files Installed on Your Computer .......... 4
- Starting the Software ................................... 5
- Uninstalling WaveStar ................................. 6
  - Automatic Uninstall .................................. 6
  - Custom Uninstall ...................................... 6

## Operating Basics

- Main Screen .................................................. 9
  - Wave Sheet ............................................... 9
  - Waveform Selection List ............................... 11
  - Picture Sheet ............................................ 12
  - Settings Sheet .......................................... 12
  - Notes Sheet ............................................. 13
  - Information on Notes .................................. 13
- Menu Bar ..................................................... 14
- Online Help .................................................. 14
  - Help Button ............................................. 14
  - Help Tool Bar Button ................................ 15
  - F1 ......................................................... 15
- Help Menu ................................................... 15
Procedures

Connecting an Oscilloscope to a Computer ................................. 17
  GPIB Communication Interface ......................................... 17
  RS-232 Communication Interface ........................................ 19
Acquiring Waveform Data from an Oscilloscope ....................... 20
  Acquire Waveforms ..................................................... 20
  Acquire Settings ....................................................... 20
  Acquire Pictures ....................................................... 21
Restoring Waveform Data to an Oscilloscope ........................... 21
  Restore Waveforms ..................................................... 21
  Restore Settings ....................................................... 21
Viewing Waveforms ........................................................ 22
  XY or YT Views ......................................................... 22
  Tabular View ............................................................ 22
Viewing the Waveform Preamble ............................................ 23
Viewing Waveform Measurements ......................................... 23
  Measurement List ....................................................... 23
Calculating and Viewing Waveform Harmonics ......................... 26
  Harmonic Graph View .................................................. 26
  Harmonic Tabular View ................................................ 26
Creating Power Waveforms ............................................... 27
Importing Waveform Data or Pictures .................................. 27
Exporting Waveform Data or Pictures .................................. 28
Viewing and Changing Waveform Information ......................... 28

Applications

Measuring Time, Voltage, Current, and Power .......................... 29
Copying the Graticule to the Clipboard ................................ 29
Copying a Picture to the Clipboard ..................................... 30
Copying Notes to the Clipboard .......................................... 30
Copying Settings to the Clipboard ....................................... 31
Pasting Spreadsheet Data into a Tabular View ......................... 31
Pasting a Tabular View into a Spreadsheet ............................. 32
Creating a Waveform in a Spreadsheet ................................ 32
Printing Records .......................................................... 33
Printing Color Waveform Data ........................................... 34
## Error Messages

- General GPIB Errors ................................................. 36
- General RS-232 Errors ............................................ 37
- Internal Errors ...................................................... 38
- General and Common Resource Errors ......................... 38

## Appendix A: Menu Commands

### File Menu .......................................................... 41
- New ........................................................................ 41
- Open ...................................................................... 41
- Close ................................................................... 41
- Save ...................................................................... 41
- Save As .................................................................. 42
- Export .................................................................... 42
- Import .................................................................... 42
- Page Setup ............................................................ 42
- Print ..................................................................... 42
- Print Preview ......................................................... 43
- Print Setup ............................................................ 43
- <recent file list> ...................................................... 43
- Exit ...................................................................... 43

### Edit Menu ............................................................. 44
- Cut - Ctrl+X ........................................................... 44
- Copy - Ctrl+C ......................................................... 44
- Paste - Ctrl+V ......................................................... 44
- Cut Wave ............................................................... 44
- Copy Wave ............................................................. 44
- Paste Wave ............................................................ 44
- Delete Wave ........................................................... 44
- Copy Sheet ............................................................. 45
- Paste Sheet ............................................................. 45
- Delete Sheet ........................................................... 45
- Waveform Preamble ................................................. 45
# Table of Contents

View Menu ..................................................... 45  
  Waveform YT .................................................. 45 
  Waveform XY .................................................. 45 
  Tabular View .................................................. 45 
  Measurements .................................................. 46 
  Harmonic ........................................................ 46 
  Harmonic Tabular ............................................ 46 
  Toolbar .......................................................... 46 
  Status Bar ....................................................... 46 
  Zoom .............................................................. 46 
  Wave Information ........................................... 46 

Insert Menu .................................................... 46  
  Wave ............................................................. 46 
  Picture ........................................................... 46 
  Settings .......................................................... 47 
  Notes .............................................................. 47 

Format Menu ..................................................... 47  
  Graticule Properties ........................................ 47 
  Picture ........................................................... 47 

Instrument Menu ................................................ 47  
  Select ............................................................. 47 
  Configure Acquire .......................................... 47 
  Acquire .......................................................... 48 
  Configure Restore .......................................... 48 

Window Menu ..................................................... 48  
  Cascade .......................................................... 48 
  Tile ................................................................. 48 
  Arrange Icons ................................................. 48 
  <open document list> ........................................ 48 

Help Menu ......................................................... 49  
  Contents ........................................................ 49 
  Search For Help On ........................................... 49 
  Index .............................................................. 49 
  Using Help ....................................................... 49 
  Getting Started .............................................. 49 
  Technical Support ............................................ 49 
  About .............................................................. 49
Appendix B: Dialog Boxes

<table>
<thead>
<tr>
<th>Dialog Box</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure Acquire</td>
<td>51</td>
</tr>
<tr>
<td>Export</td>
<td>51</td>
</tr>
<tr>
<td>Format Picture</td>
<td>52</td>
</tr>
<tr>
<td>Graticule Properties</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Graticule Tab</td>
<td>52</td>
</tr>
<tr>
<td>Plot Tab</td>
<td>52</td>
</tr>
<tr>
<td>Color Tab</td>
<td>53</td>
</tr>
<tr>
<td>Text Tab</td>
<td>53</td>
</tr>
<tr>
<td>Import</td>
<td>53</td>
</tr>
<tr>
<td>Open</td>
<td>54</td>
</tr>
<tr>
<td>Page Setup</td>
<td>54</td>
</tr>
<tr>
<td>Print</td>
<td>55</td>
</tr>
<tr>
<td>Print Options</td>
<td>55</td>
</tr>
<tr>
<td>Print Setup</td>
<td>56</td>
</tr>
<tr>
<td>Rename Sheet</td>
<td>56</td>
</tr>
<tr>
<td>Restore</td>
<td>57</td>
</tr>
<tr>
<td>Save / Save As</td>
<td>57</td>
</tr>
<tr>
<td>Select Instrument</td>
<td>57</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>GPIB Settings Tab</td>
<td>58</td>
</tr>
<tr>
<td>RS-232 Settings Tab</td>
<td>58</td>
</tr>
<tr>
<td>Waveform Preamble</td>
<td>59</td>
</tr>
<tr>
<td>Waveform Information</td>
<td>60</td>
</tr>
</tbody>
</table>

Appendix C: RS-232 Interface Reference

<table>
<thead>
<tr>
<th>Reference</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oscilloscope Requirements</td>
<td>61</td>
</tr>
<tr>
<td>11000 Series</td>
<td>61</td>
</tr>
<tr>
<td>TDS 200 or 300 Series</td>
<td>62</td>
</tr>
<tr>
<td>TDS 400, 500, 600, 700, or 800 Series</td>
<td>62</td>
</tr>
<tr>
<td>2221</td>
<td>63</td>
</tr>
<tr>
<td>RS-232 General Hints</td>
<td>63</td>
</tr>
<tr>
<td>RS-232 Cable Issues</td>
<td>65</td>
</tr>
<tr>
<td>RS-232 Cable Examples</td>
<td>65</td>
</tr>
<tr>
<td>11000 Series Oscilloscope to Computer (DB25 male to DB9 female)</td>
<td>66</td>
</tr>
<tr>
<td>11000 Series Oscilloscope to Computer (DB25 female to DB25 male)</td>
<td>66</td>
</tr>
</tbody>
</table>
Preface

This manual supports the WSTR31 WaveStar™ Software, and the WSTR31U DocuWave™ Upgrade to WaveStar software.

WaveStar software is a Windows utility application that acquires, displays, prints, and exports waveforms and screen images from digital storage oscilloscopes as graphic images or as data values.

WaveStar software includes tools to collect, organize, annotate, and document measurements taken with Tektronix oscilloscopes. You can use these tools to perform the following tasks:

- Export waveform images and settings in Excel™ 4.0 (XLS) and DocuWave (CSV) formats.
- Import waveform images and settings in TDS waveform (ISF and WFM), 11K series (WFB), and DocuWave (CSV) formats.
- Copy waveform images and settings to the clipboard for use in spreadsheet and documentation applications.
- Display waveform data in tabular, measurement, and harmonic views.
- Create power waveforms.

Conventions

This manual uses the following conventions:

- The term “software” includes all WaveStar products unless noted otherwise.
- The term “computer” refers to any system running Windows 3.1 or Windows 95.
- The term oscilloscope refers to any Tektronix digital storage oscilloscope that is compatible with WaveStar software.
Contacting Tektronix

Product Support   For application-oriented questions about a Tektronix measurement product, call toll free in North America:
                  1-800-TEK-WIDE (1-800-835-9433 ext. 2400)
                  6:00 a.m. – 5:00 p.m. Pacific time
                  Or contact us by e-mail:
                  tm_app_supp@tek.com
                  For product support outside of North America, contact your local Tektronix distributor or sales office.

Service Support   Contact your local Tektronix distributor or sales office. Or visit our web site for a listing of worldwide service locations.
                  http://www.tek.com
                  For other information
                  In North America:
                  1-800-TEK-WIDE (1-800-835-9433)
                  An operator will direct your call.

To write us       Tektronix, Inc.
                  P.O. Box 1000
                  Wilsonville, OR 97070-1000
Getting Started

Your computer must meet the following minimum requirements:

- DOS-compatible 386 system (486 or greater recommended)
- Windows 3.1 or Windows 95 in 386 enhanced mode
- 4 MB RAM
- 5 MB hard disk space
- 3.5” high density floppy disk drive
- VGA monitor
- GPIB National Instruments IEEE-488 Interface Card, or a compatible serial communications port and RS-232 cable

Table 1 lists oscilloscopes with which WaveStar software is compatible. The restore and settings columns show if the software can send information back to the oscilloscope. The picture column shows if the software can acquire data in a graphic format.

Table 1: Compatible oscilloscopes and available functions

<table>
<thead>
<tr>
<th>Tektronix instrument1</th>
<th>GPIB/RS-232</th>
<th>Restore</th>
<th>Settings</th>
<th>Picture</th>
</tr>
</thead>
<tbody>
<tr>
<td>11401, 11402/A, 11403/A, 11801/B, 11802, CSA404, CSA803/A, DSA601/A, DSA602/A</td>
<td>Both</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>2212, 2216, 2430/A, 2432/A, 2440</td>
<td>GPIB</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>2220, 2221A, 2230, 2232</td>
<td>Both</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>TDS 200, TDS 300 Series</td>
<td>Both</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>TDS 400, TDS 500, TDS 600, TDS 700, TDS 800 Series</td>
<td>GPIB</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>THS 700 Series</td>
<td>RS-232</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

1 Contact your Tektronix sales representative for a current list of instruments.

2 Differential TDR is not available.
NOTE. You can order and use the WSTROU WaveStar software if you are upgrading your computer to run NT or Windows 98.

Upgrades

You can receive upgrades, if any, when they are available provided that you have purchased WaveStar software version 1.0. The upgrade installation aborts if it cannot find files for WaveStar V1.0 or later.

You can install the WSTR31U DocuWave upgrade that contains the WaveStar software only if the S60 DWA V DocuWave software already resides on your computer.

Web Site

You can download upgrades from the Tektronix, Inc. web site at http://www.tek.com/Measurement/Support.

Floppy Disks

If you do not have access to the web site, Technical Support can send you an upgrade on floppy disks. For information on how to contact Technical Support, refer to Contacting Tektronix on page viii.
Installation Procedures

You can install the WSTR31 software on a computer that meets the minimum system requirements described in *Getting Started* on page 1.

You can install WSTR31U DocuWave Upgrade to WaveStar only on a computer that contains S60 DWAV DocuWave software and its related data files. The WSTR31U installation aborts if the DocuWave software files are not found during the installation process.

The installation process for upgrades checks for existing WaveStar software files on your computer. You cannot load the upgrade version if you do not currently have WaveStar software on your computer.

If you have problems using other applications on your computer after installing this software, refer to the INSTALL.LOG file in the WaveStar directory for a list of system files replaced during the installation. If you choose the backup option during installation, the replaced system files are stored in the “backup” directory.

Installing the Software

There are several ways to install the WaveStar software: using the Windows Program Manager, the File Manager, or Windows 95.

---

**NOTE.** You can order and install the WSTROU WaveStar software if you are upgrading your computer to run NT or Windows 98.

---

**Using the Windows Program Manager**

1. Close all open applications on your computer.
2. Insert the first WaveStar floppy disk.
3. Open the Windows Program Manager dialog box and select Run from the File menu.
4. Type “a:\setup” or “b:\setup” in the Command Line entry field, depending on which directory your floppy disk drive is assigned.

5. Click OK, or press Return.

**Using the File Manager**

1. Close all open applications on your computer.
2. Insert the first WaveStar floppy disk.
3. Double-click the File Manager icon in the Program Manager dialog box.
4. From the File Manager toolbar, select the disk drive containing the WaveStar floppy disk.
5. Double-click the “setup.exe” file in the file list, or select “setup.exe” and choose Open from the File menu.

**Using Windows 95**

1. Close all open applications on your computer.
2. Insert the first WaveStar floppy disk.
3. Click Start in the Windows 95 main screen. This displays a task list.
4. From the task list, select Run... This displays the Run dialog box.
5. Type “a:\setup.exe” or “b:\setup” in the entry field and click OK.

**System Files Installed on Your Computer**

The WaveStar software installs many files, shown in Table 2, in the WaveStar and System directories on your computer. All replaced files will be preserved in the Backup directory if you choose that option during installation.

**NOTE**  Do not delete these files when uninstalling this software, until you verify that the file will not be used by any other applications.
Table 2: System files installed

<table>
<thead>
<tr>
<th>Installed file</th>
<th>Directory location</th>
</tr>
</thead>
<tbody>
<tr>
<td>HYPERVIEW.HLP</td>
<td>WAVESTAR</td>
</tr>
<tr>
<td>HYPRFIND.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>HYPRVIEW.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>COMPOBJ.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>MFCOLEUI.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>OLE2.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>OLE2DISP.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>OLE2NLS.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>STRAGE.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>TOOLHELP.DLL</td>
<td>WINDOWS\SYSTEM</td>
</tr>
<tr>
<td>CTL3DV2.DLL(^1)</td>
<td>WINDOWS\SYSTEM</td>
</tr>
</tbody>
</table>

\(^1\) This file is commonly used by other applications. Do not delete this file during the Custom Uninstall process unless you are sure it is not used by other applications.

### Starting the Software

The software installation procedure automatically creates a Windows Group window and icons.

To start the software, follow these steps:

1. After starting Windows, open the WaveStar program group window.

2. Double-click the WaveStar notebook icon.

See *Operating Basics* on page 9 for detailed information on the WaveStar features and user interface.
Uninstalling WaveStar

There are two uninstall processes: automatic and custom.

**NOTE. To avoid accidentally deleting files needed by other programs, read Automatic Uninstall and Custom Uninstall before you proceed.**

To uninstall the software, open the WaveStar program group window in the Program Manager window. Double-click the uninstall WaveStar icon. The Select Type of Uninstall window appears and asks you which type of uninstall process you want to perform.

**Automatic Uninstall**

The Automatic Uninstall process deletes all WaveStar files and all associated data files. If you are sure that you want to permanently remove all WaveStar data files, use the automatic uninstall process. Read through the *Custom Uninstall* information before proceeding with an Automatic Uninstall. Deleting certain data files may interrupt other applications that may also use the files.

**Custom Uninstall**

Choosing Custom Uninstall allows you to select which WaveStar data files you want to remove. You might want to do this because there are some data files that may be used by other applications. Table 3 lists some data files you may not want to remove.

Before deleting all data files, make sure that other applications are not using the files listed in Table 2 and Table 3.

Table 3: WaveStar files you may not want to delete

<table>
<thead>
<tr>
<th>Filename</th>
<th>What the file does</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNWISE.EXE</td>
<td>After installing WaveStar software, do not delete this file. UNWISE is the uninstall program. If you delete this file, you will not be able to uninstall the WaveStar software simply.</td>
</tr>
</tbody>
</table>
Table 3: WaveStar files you may not want to delete (cont.)

<table>
<thead>
<tr>
<th>Filename</th>
<th>What the file does</th>
</tr>
</thead>
<tbody>
<tr>
<td>INSTALL.LOG</td>
<td>This is a file associated with the uninstall program. It is created when you install WaveStar software, and contains an ASCII list of all files installed on your computer during the WaveStar installation process. Use Notepad to view this file.</td>
</tr>
<tr>
<td>HYPRFIND.DLL</td>
<td>These files enable the HyperView and Find+ commands in WaveStar Online Help. They are located in the Windows System directory, and may be used by other software applications. Deleting these files may disrupt other files that use the .DLL files, so it’s important to determine if these files are used by other software applications before deleting them.</td>
</tr>
<tr>
<td>HYPRVIEW.DLL</td>
<td></td>
</tr>
</tbody>
</table>

During the Custom Uninstall process you are asked to select data files, system files, directories, and icon files you want to remove.

Below are the prompts that appear during the uninstall process and a description of the files you are asked to delete.

“Files to Remove”. Lists data files in the WaveStar directory.

“Select System Files to Remove”. WaveStar software places some files in your Windows System directory: UNWISE.EXE, INSTALL.LOG, HYPRFIND.DLL, and HYPRVIEW.DLL. Refer to the file descriptions in Table 3 to determine which Windows System files to remove.

“Select Directories to Remove”. During the install process you are asked to choose a name for the directory where the WaveStar data files are placed. By default, this directory is titled “WaveStar.”

**NOTE.** Do not delete this directory if you are leaving any data files in place. To do so deletes all files contained within the directory.

“Select Icons to Remove”. Choose which WaveStar icons you wish to remove. If you are only deleting certain files, refer to the list of files in Table 3 to determine which icons to retain.
When you choose OK in the Select Icons to Remove dialog box, the uninstallation process begins. A dialog box appears showing the percent of the process that is complete. If you want to cancel the process while it is running, click the Cancel button.
Operating Basics

This section contains information on operating basics. Specific procedures are shown in the Procedures section on page 17.

Main Screen

The software main screen displays waveforms and pictures exactly as they appear on your oscilloscope and contains four individual sheets in each notebook file.

NOTE. If a feature, button, or command is not supported, the software grays out or disables the control.

Wave Sheet

The Wave sheet displays waveform data exactly as it appears on your oscilloscope. There are a number of different controls on the Wave Sheet dialog box.

Menu Bar. The menu bar contains pulldown menus that contain features and commands. To pull down a menu, click the name of the menu or use an Alt key combination as described on page 14.

Tool Bar. The tool bar contains buttons that control various features. When you point to a button with the mouse, the software displays an abbreviated title of the feature.

Figure 1 shows the location of the menu bar and the tool bar.

Figure 1: Menu bar and tool bar locations
Waveforms. Waveforms are displayed in the graticule area of the Wave sheet exactly as they are shown on the oscilloscope. You can use the Waveform Information command under the View menu to change the colors (as described on page 28) and display options.

Waveform Number. Each waveform is assigned a unique waveform number. You can use the mouse to select and move, cut, copy, or paste waveforms on the graticule.

Graticule. This is the grid on which the waveforms are displayed.

Trigger Point. A “T” on the graticule represents the trigger point.

Figure 2 shows the location of the waveform, the waveform number, the graticule, and the trigger point.

Figure 2: Graticule features

Cursor Positions and Type. The cursor type list box lists the different types of cursor displays: none, vertical, horizontal, paired, and crosshair. When a cursor type is selected, cursor position values appear in the dX, X, and Y fields in the list box.

Vertical Scale. Controls the vertical scale value of the graticule.

Vertical Position Buttons. Controls the vertical position of a waveform.

Horizontal Scale. Controls the horizontal scale value of the graticule.
**Horizontal Position Buttons.** Controls the horizontal position of a waveform.

**Waveform Selection List**

Each acquired waveform in the open notebook is listed by its waveform number, measurements, and name.

**Waveform Numbers.** Each waveform is assigned a number which is listed in the waveform selection list and on the graticule. Select a waveform selection button to display that waveform on the graticule.

**Waveform Selection Buttons.** Select and deselect the check boxes to toggle the selection and display of the waveform on the graticule.

Figure 3 shows the location of the cursor positions, the type list boxes, the vertical and the horizontal scale list boxes, the vertical and the horizontal position buttons, and the waveform selection list, number, and selection buttons.

---

**Figure 3: Waveform data, position, and scale**
Status Bar. The status bar displays messages.

Sheet Position Buttons. Use these buttons to scroll through the sheet tabs if you have a large number of sheets in your notebook file and your monitor is not wide enough to display all of the tabs.

Figure 4 shows the location of the sheet tabs and status bar.

![Sheet tabs and status bar]

**Picture Sheet**

The Picture sheet contains a hardcopy image of the oscilloscope display. You can use the Picture command under the Format menu to control the picture image.

You can copy a picture image to the clipboard for use in other applications as described on page 30; however, you cannot edit the picture image from within the WaveStar software. The only changes you can make to the picture image are changing the position of the picture and setting the rotation in the Format Picture dialog box.

**NOTE**. The software can also export or import picture files as described in the procedures on page 27.

**Settings Sheet**

The Settings sheet contains ASCII text settings acquired during the waveform acquisition. You can copy text from the Settings sheet for use in other applications. You can restore these settings to the oscilloscope using the Restore command under the Instrument menu.
Refer to Restoring Waveform Data to the Oscilloscope on page 21 for further information.

Notes Sheet

You can use the Notes sheet to record notes about the open notebook file. These are NOT the same notes that appear on the graticule.

You can edit, cut, copy, and paste notes from the Notes sheet to and from the clipboard for use with other applications.

\[\text{NOTE. There are three separate areas for notes in a notebook file. Each area controls different aspects of notebook file notes.}\]

Information on Notes

There are three different ways in which you can record notes: the Notes sheet, the Rename Sheet dialog box, and the Waveform Information dialog box.

Notes Sheet. The Notes sheet is a place to record and save notes about the notebook file.

You can not display these notes on the graticule.

Rename Sheet Dialog Box Notes. The Notes field in the Rename Sheet dialog box is where you can enter notes about the waveform to display on the graticule.

\[\text{NOTE. To display notes on the graticule, you must enter the text in the Notes field of the Rename Sheet dialog box and choose to display them in the Graticule Properties Text dialog box.}\]

Waveform Information Dialog Box Notes. Each waveform has its own Waveform Information dialog box. The Notes field in this dialog box allows you to save text notes related to the selected waveform.

You can not display these notes on the graticule.
Menu Bar

The menu bar controls a number of features not contained in the tool bar. You can access the menu commands using the mouse to pull down the menu or the ALT buttons.

The ALT button combinations and function are as follows:

- <ALT-F> pulls down the File menu.
- <ALT-E> pulls down the Edit menu.
- <ALT-V> pulls down the View menu.
- <ALT-I> pulls down the Insert menu.
- <ALT-R> pulls down the Format menu.
- <ALT-N> pulls down the Instrument menu.
- <ALT-W> pulls down the Window menu.
- <ALT-H> pulls down the Help menu.

After pulling down a menu, select a menu command by typing the letter underlined in the command. For example, to start a new file, press <ALT-F> to pull down the File menu, and then type “n”, since the “n” is underlined in the New command.

Appendix A: Menu Commands, beginning on page 41, contains detailed information about what each menu command controls.

Online Help

The software contains a detailed online help system. The help contains information on menu commands, main screen features and controls, procedures, dialog boxes, error messages, GPIB and RS-232 connections, and technical support.

Help Button

Each dialog box and error message box contains a Help button. Click the Help button to access the help related to that particular dialog box or error message.
Help Tool Bar Button
The tool bar contains a Help button. Click the Help button and then click an area of the screen to display help about the selected feature.

F1
Pressing F1 and then using the mouse to click a screen or menu area works the same way as using the Help button in the tool bar.

Help Menu
The Help menu contains six menu commands that all access help as follows:

Contents. Activates the software main help screen.

Search For Help On... Activates a search dialog box that allows you to search for help topics using a keyword search.

Index. Activates the help index where all topics are listed alphabetically.

Using Help. Activates the Using Online Help dialog box that describes how to use help in general (not specific to the help).

Getting Started. Activates an online tutorial in the software help. The Getting Started help takes you through a series of procedures to familiarize you with the software.

Technical Support. Activates the help screen containing information on how to contact Tektronix Technical Support.
Procedures

This section describes how to connect your oscilloscope to a computer, and includes procedures on how to use the WaveStar software to perform the following tasks:

- Acquire and restore waveforms
- Import and export waveforms
- View and manipulate settings
- Take power analysis measurements

Connecting an Oscilloscope to a Computer

You can connect your oscilloscope to a computer through one of two communication interfaces: GPIB or RS-232.

GPIB Communication Interface

Table 4 list the equipment you need to make a GPIB connection.

Table 4: GPIB communication interface equipment

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Minimum requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>GPIB interface card</td>
<td>National Instruments IEEE-488.2 interface card.</td>
</tr>
<tr>
<td>GPIB cable</td>
<td>--</td>
</tr>
<tr>
<td>Oscilloscope</td>
<td>Compatible with WaveStar software (Table 1 on page 1)</td>
</tr>
<tr>
<td>Computer</td>
<td>386, 4MB RAM, 5MB hard disk space, VGA monitor, Windows 3.1 or Windows 95, 3.5 high density floppy drive. See Getting Started on page 1.</td>
</tr>
</tbody>
</table>
To connect your oscilloscope to a GPIB port, follow these steps:

1. Check the GPIB address of your oscilloscope. This is an oscilloscope function, so refer to the oscilloscope user manual for information on how to check the GPIB address.

2. Click the Instrument Select button located in the toolbar (or choose Select from the Instrument menu). The Instrument Select dialog box appears. Select your oscilloscope from the instrument list.

3. If you want to save the type of oscilloscope, change the instrument select defaults by checking the Save As Defaults box.

4. Select the GPIB Settings tab in the Instrument Select dialog box and change the Address to match the GPIB address of your oscilloscope.

5. When you’re finished with the previous steps, select the TEST button to test your GPIB connection. One of three messages will appear:
   - “GPIB Connection OK” -- Your GPIB connection is good.
   - “No GPIB Board Found” -- There is an error in your GPIB connection. Either refer to your National Instruments user manual for further GPIB information or contact National Instruments.
   - “Scope Mismatch” -- You are trying to connect to an oscilloscope different than the oscilloscope selected. Verify that you have chosen the correct oscilloscope from the list in the Instrument Select dialog box.

6. When you have successfully established a GPIB connection to your oscilloscope, click OK.

**Resolving GPIB Problems.** If you have difficulty with establishing a GPIB interface connection, follow these steps:

1. Disconnect all GPIB cables from your computer.

2. Run the hardware diagnostics supplied with the GPIB card.

3. Run the software diagnostics supplied with the GPIB card.
4. If the GPIB diagnostics fail, or if you have difficulty running them, contact National Instrument Technical Support.

5. If the GPIB diagnostics pass and you still cannot establish a GPIB connection, contact Tektronix Technical Support as described on page viii.

**RS-232 Communication Interface**

Table 5 lists the equipment you need to make an RS-232 connection.

**Table 5: RS-232 communication interface equipment**

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Minimum requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>RS-232 cable</td>
<td>Verify that the cable has the same pin numbers and assignments to match both the oscilloscope and computer RS-232 (serial) ports.</td>
</tr>
<tr>
<td>Oscilloscope</td>
<td>Compatible with WaveStar software (Table 1 on page 1)</td>
</tr>
<tr>
<td>Computer</td>
<td>386, 4MB RAM, 5MB hard disk space, VGA monitor, Windows 3.1 or later, 3.5” high density floppy drive. See &quot;Getting Started&quot; on page 1.</td>
</tr>
</tbody>
</table>

To connect your oscilloscope to an RS-232 port, follow these steps:

1. Click the Instrument Select button located in the WaveStar toolbar or select Select from the Instrument menu.

2. The Instrument Select dialog box appears. Select your oscilloscope from the instrument list in this dialog box.

3. Change the instrument select defaults by selecting the Defaults button and set the instrument defaults to match your oscilloscope:
   - **PORT**: Select the computer port through which you’ll make the RS-232 connection.
   - **BAUD**: This selection appears for oscilloscopes that do not automatically detect the baud rate. If this appears, select the baud rate at which the RS-232 connection will operate.
   - **TIMEOUT**: Select the timeout time.
TEST button: After setting the RS-232 settings, select the TEST button to test the connection. One of two messages will appear:

- **“RS-232 Connection OK”** - The RS-232 connection is successfully established.
- **“Bad RS-232 Port”** - There is an error in your RS-232 connection. Verify that the correct port and baud rates are entered for your particular computer and oscilloscope.

4. When you have successfully established an RS-232 connection to your oscilloscope, click OK.

If you have difficulty establishing an RS-232 interface connection, refer to Appendix C: RS-232 Interface Reference on page 61.

### Acquiring Waveform Data from an Oscilloscope

The software allows you to acquire waveforms, settings, and pictures from oscilloscopes.

#### Acquire Waveforms

To acquire a waveform from the oscilloscope, follow these steps:

1. Make sure the GPIB or RS-232 connection from the computer to the oscilloscope is established and in working order.
2. Select the Wave sheet in the open WaveStar notebook.
3. Either click the Acquire Waveform button in the toolbar or select Acquire from the Instrument menu.

#### Acquire Settings

To acquire settings from your oscilloscope, follow these steps:

1. Make sure the GPIB or RS-232 connection from the computer to the oscilloscope is established and in working order.
2. Select the Settings tab in the open WaveStar notebook.
3. Either click the Acquire Waveform button in the toolbar or select Acquire from the Instrument menu.
Acquire Pictures
To acquire a picture from your oscilloscope, follow these steps:

1. Make sure the GPIB or RS-232 connection from the computer to the oscilloscope is established and in working order.
2. Select the picture sheet in the open WaveStar notebook.
3. Either click the Acquire Waveform button in the toolbar or select Acquire from the Instrument menu.

Restoring Waveform Data to an Oscilloscope
The software allows you to restore waveforms and settings to oscilloscopes.

NOTE. You cannot restore pictures to an oscilloscope.

Restore Waveforms
After you acquire and save a waveform from an oscilloscope, the software allows you to restore the waveform to the oscilloscope.

To restore a waveform to your oscilloscope, follow these steps:

1. Select the Wave tab at the bottom of the open WaveStar notebook.
2. Choose Restore from the Instrument menu; the Restore dialog box appears.
3. Select the waveform name, the destination, and click OK.

Restore Settings
After you acquire and save settings from an oscilloscope, the software allows you to restore the settings to the oscilloscope. The waveform settings are located on the Settings sheet.

To restore waveform settings to your oscilloscope, follow these steps:

1. Select the Settings tab at the bottom of the open WaveStar notebook.
2. Choose Restore from the Instrument menu; the WaveStar Windows Applications dialog box appears with the question "Do you want to copy the current settings to the scope?"

3. Click Yes.

Viewing Waveforms

The software allows you to view waveform data in many different ways: XY, YT, tabular, measurement, harmonic bar graph, and harmonic tabular views.

XY or YT Views
To display two waveforms in XY or YT view, follow these steps:

1. Select the Wave sheet.

2. If you want to display an XY view, click an X source and click a Y source waveform box from the list of waveforms.
   If you want to display a YT view, click the appropriate waveform boxes in the list of waveforms.

3. Either click the View XY or View YT button in the toolbar or select Waveform XY or Waveform YT from the View menu.

Tabular View
To display waveforms in tabular view, follow these steps:

1. Select waveforms to display from the waveform list box in the lower left corner of the waveform sheet.

2. If you want to display an XY view, click an X source and click a Y source waveform box from the list of waveforms.
   If you want to display a YT view, click the appropriate waveform boxes in the list of waveforms.

3. Either click the Tabular View button in the toolbar or select Tabular View from the View menu.
Viewing the Waveform Preamble

In addition to the tabular view, the software also allows you to view and edit the waveform preamble using the Waveform Preamble command under the Edit menu.

Each point in the waveform returned from the oscilloscope is an integer. For an 8-bit oscilloscope the range is -128 to 127. Any value outside of the range will cause an error.

Each waveform has an associated waveform preamble. The data in the waveform preamble determines how to convert the oscilloscope waveform into real numbers, which you see in the Waveform Preamble dialog box.

For additional information on the waveform preamble, refer to the programmer manual for your oscilloscope.

For a list of the fields and a brief description of each one, refer to Waveform Preamble on page 59.

Viewing Waveform Measurements

To display waveform measurements, follow these steps:

1. Select waveforms to display from the waveform listbox in the lower left corner of the waveform sheet.

2. Click the Measurement button in the toolbar or select Measurement from the View menu.

Measurement List

With the click of the Measurements button, WaveStar software calculates more than twenty measurements on each waveform and displays them in tabular view for easy side-by-side comparison.

Table 6 lists each measurement and its definition.
### Table 6: Waveform measurement definitions

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>AC RMS</td>
<td>AC voltage measurement. The AC true Root Mean Square voltage over the entire waveform.</td>
</tr>
<tr>
<td>Amplitude</td>
<td>Voltage measurement. The high value less the low value measured over the entire waveform.</td>
</tr>
<tr>
<td>Burst width</td>
<td>Timing measurement. The duration of a burst. Measured over the entire waveform.</td>
</tr>
<tr>
<td>Cycle mean</td>
<td>Voltage measurement. The arithmetic mean over the first cycle in the waveform.</td>
</tr>
<tr>
<td>Cycle RMS</td>
<td>Voltage measurement. The true Root Mean Square voltage over the first cycle in the waveform.</td>
</tr>
<tr>
<td>Cycle AC RMS</td>
<td>AC voltage measurement. The AC true Root Mean Square voltage over the first cycle in the waveform.</td>
</tr>
<tr>
<td>Fall time</td>
<td>Timing measurement. Time taken for the falling edge of the first pulse in the waveform to fall from a High Ref value (default = 90%) to a Low Ref value (default = 10%) of its final value.</td>
</tr>
<tr>
<td>Frequency</td>
<td>Timing measurement for the first cycle in the waveform. The reciprocal of the period. Measured in Hertz (Hz) where 1 Hz = 1 cycle per second.</td>
</tr>
<tr>
<td>High</td>
<td>The value used as 100% whenever High Ref, Mid Ref, and Low Ref values are needed (as in fall time and rise time measurements). Calculated using either the min/max or the histogram method. The min/max method uses the maximum value found. The histogram method uses the most common value found above the midpoint. Measured over the entire waveform.</td>
</tr>
<tr>
<td>Low</td>
<td>The value used as 0% whenever High Ref, Mid Ref, and Low Ref values are needed (as in fall time and rise time measurements). May be calculated using either the min/max or the histogram method. With the min/max method it is the minimum value found. With the histogram method, it refers to the most common value found below the midpoint. Measured over the entire waveform.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Voltage measurement. The maximum amplitude. Typically the most positive peak voltage. Measured over the entire waveform.</td>
</tr>
<tr>
<td>Mean</td>
<td>Voltage measurement. The arithmetic mean over the entire waveform.</td>
</tr>
</tbody>
</table>
Table 6: Waveform measurement definitions (cont.)

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum</td>
<td>Voltage measurement. The minimum amplitude. Typically the most negative peak voltage. Measured over the entire waveform.</td>
</tr>
<tr>
<td>Peak to peak</td>
<td>Voltage measurement. The absolute difference between the maximum and minimum amplitude in the entire waveform.</td>
</tr>
<tr>
<td>Period</td>
<td>Timing measurement. Time it takes for the first complete signal cycle to happen in the waveform. The reciprocal of frequency. Measured in seconds.</td>
</tr>
</tbody>
</table>
| Positive duty cycle | Timing measurement of the first cycle in the waveform. The ratio of the positive pulse width to the signal period expressed as a percentage.  
\[ PositiveDutyCycle = \frac{PositiveWidth}{Period} \times 100\% \]  |
| Positive overshoot  | Voltage measurement over the entire waveform.  
\[ PositiveOvershoot = \frac{Max-High}{Amplitude} \times 100\% \]  |
| Positive pulse width| Timing measurement of the first pulse in the waveform. The distance (time) between MidRef (default 50%) amplitude points of a positive pulse. |
| Negative duty cycle | Timing measurement of the first cycle in the waveform. The ratio of the negative pulse width to the signal period expressed as a percentage.  
\[ NegativeDutyCycle = \frac{NegativeWidth}{Period} \times 100\% \]  |
| Negative overshoot  | Voltage measurement. Measured over the entire waveform.  
\[ NegativeOvershoot = \frac{Low-Min}{Amplitude} \times 100\% \]  |
| Negative pulse width| Timing measurement of the first pulse in the waveform. The distance (time) between MidRef (default 50%) amplitude points of a negative pulse. |
Table 6: Waveform measurement definitions (cont.)

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rise time</td>
<td>Timing measurement. Time taken for the leading edge of the first pulse in the waveform to rise from a Low Ref value (default = 10%) to a High Ref value (default = 90%) of its final value.</td>
</tr>
<tr>
<td>RMS</td>
<td>Voltage measurement. The true Root Mean Square voltage over the entire waveform.</td>
</tr>
</tbody>
</table>

Calculating and Viewing Waveform Harmonics

The software includes harmonic calculations, and two types of views, graph and tabular.

Harmonic data allows you to determine the distortion in your line measurements. You can use this data to verify that your line distortion measurements meet standards such as IEEE519 and IEC1000.

**Harmonic Graph View**

To view waveforms in harmonic graph view, follow these steps:

1. Select the wave sheet tab.
2. Either click the Harmonic Graph button in the toolbar or select the Harmonic command from the View menu.
3. Select settings in each of the four list boxes: Voltage, Current, Number of Harmonics, and Type.
4. Click the Calculate Harmonic Data button.

**Harmonic Tabular View**

To view waveforms in harmonic tabular view, follow these steps:

1. Select the wave sheet tab.
2. Click the Harmonic Tabular button in the toolbar or select the Harmonic Tabular command from the View menu.
3. Select settings in each of the four list boxes: Voltage, Current, Number of Harmonics, and Type.
4. Click the Calculate Harmonic Data button.

Creating Power Waveforms

If your oscilloscope is not capable of creating power waveforms from voltage and current waveforms, you can acquire the voltage and current waveforms and let the software do the work.

Make sure you have acquired both a voltage waveform and current waveform. To create a power waveform, follow these steps:

1. Either click the Harmonic button in the toolbar or select Harmonic from the View menu.
2. In the Harmonic view, select the voltage and current waveforms in the Voltage and Current pulldown lists, respectively.
3. Click the Create Power Waveform button.

The software multiplies the voltage waveform by the current waveform, creating a new power waveform. This new power waveform is listed in the waveform selection box in the wave sheet.

Importing Waveform Data or Pictures

The software allows you to import TDS waveform (ISF and WFM), 11K000 series (WFB), and DocuWave (CSV) files and convert them into WaveStar files. If you attempt to import a file in any other format, the software displays the “Improper File Format” error message.

You can also import images as picture files if the images are in a .bmp or a .dib format.

To import waveform data or a picture file into the software, follow these steps:

1. Click the appropriate tab, either Wave or Picture.
2. Select the Import command from the File menu.
3. Select the file to import from the file list in the Import dialog box.
4. Click OK.
The software lists imported waveforms in the Wave Sheet dialog box and imported picture files in the Picture Sheet dialog box.

**Exporting Waveform Data or Pictures**

The software allows you to export waveform data in Excel 4.0 (XLS) and DocuWave (CSV) formats.

You can also export picture files in a .bmp or a .dib format.

To export waveform data or a picture file from the software, follow these steps:

1. Click the appropriate tab, either Wave or Picture.
2. Select the Export command from the File menu.
3. Enter the destination filename and location in the Export dialog box.
4. Click OK.

The exported file will appear in the destination location you specified in step 3.

**Viewing and Changing Waveform Information**

The Waveform Information dialog box lists unique waveform information about each waveform.

To view and make changes to the waveform information for the selected waveform, including changing the display color, follow these steps:

1. Double-click the waveform name in the waveform list box, or select a waveform number on the graticule and then select Wave Information... from the View menu.
2. Change the color of the waveform and add waveform notes in the Waveform Information dialog box that appears.
3. When you are done, click OK.
Applications

You can use the software to help you perform the following tasks:

- Make measurements
- Transfer waveform data to other Windows applications, such as word processors, spreadsheets, and desktop publishing
- Paste data from other Windows applications into a notebook
- Print records

Measuring Time, Voltage, Current, and Power

To measure time, voltage, current, or power of a single waveform or between multiple waveforms on the graticule, follow these steps:

1. Select the Wave sheet.
2. Select a type of cursor from the Cursor list box.
3. Place the cursors on the waveforms where you want to make the measurements.

   X1 and X2 Cursor Positions measure absolute time.
   
   Y1 and Y2 Cursor Positions measure absolute voltage, current, or power.
   
   dX and dY Cursor Positions measure the difference between the two cursors positions.

Copying the Graticule to the Clipboard

The software allows you to copy the entire graticule with waveforms, trigger points, scales and other information to the clipboard for use in other Windows applications.
To copy the graticule to the clipboard, follow these steps:

1. Select the wave sheet.
2. Select Copy from the Edit menu.
3. Open another Windows application such as Microsoft Word.
4. Insert the cursor where you want to paste the graticule image.
5. Select Paste from the application’s Edit menu.

**Copying a Picture to the Clipboard**

The software allows you to capture a hardcopy image of the oscilloscope display. This image is located in the picture sheet.

To copy the picture image to the clipboard for use with other applications, follow these steps:

1. Select the picture sheet.
2. Select Copy from the Edit menu.
3. Open another Windows applications such as Microsoft Word.
4. Insert the cursor where you want to paste the graticule image.
5. Select Paste from the application’s Edit menu.

**Copying Notes to the Clipboard**

The software allows you to either copy the entire notes sheet to the clipboard or copy only part of the notes to the clipboard.

To copy either the entire notes sheet or just a portion of the notes to the clipboard, follow these steps:

1. Select the notes sheet.
2. Use the mouse to select the portion of notes you wish to copy to the clipboard. If you are copying the entire notes sheet, go directly to step 3.
3. Select Copy from the Edit menu.
4. Open another Windows applications such as Microsoft Word.

5. Insert the cursor in the Microsoft Word file where you want to paste the notes.

6. Select Paste from Word’s Edit menu.

### Copying Settings to the Clipboard

The software allows you to either copy the entire settings sheet to the clipboard or copy only part of the settings to the clipboard:

To copy either the entire settings sheet or just a portion of the settings to the clipboard, follow these steps:

1. Select the settings sheet.

2. Use the mouse to select the portion of settings you wish to copy to the clipboard. If you are copying the entire settings sheet, go directly to step 3.

3. Select Copy from the Edit menu.

4. Open another Windows applications such as Microsoft Word.

5. Insert the cursor in the Microsoft Word file where you want to paste the settings.

6. Select Paste from Word’s Edit menu.

### Pasting Spreadsheet Data into a Tabular View

The software allows you to paste areas from spreadsheet applications, such as Microsoft Excel, into the tabular view of a notebook.

To paste an area from a spreadsheet application into a notebook, follow these steps:

1. Open the spreadsheet file from which you wish to paste.

2. Use the mouse to select the spreadsheet area you wish to paste into a notebook and select Copy from the Edit menu.

3. Open the notebook file in which you wish to paste.
4. Select the Wave sheet and set the waveform to tabular view. To do this, click the Tabular View button in the toolbar or select Tabular from the View menu.

5. Insert the cursor in the tabular view display and select Paste from the Edit menu.

Pasting a Tabular View into a Spreadsheet

The software allows you to paste areas from the tabular view into spreadsheet applications such as Microsoft Excel. This feature is especially helpful if you want to use a spreadsheet to create a new waveform and then restore the waveform to your oscilloscope.

To paste an area from the tabular view into a spreadsheet application, follow these steps:

1. Open the notebook file and select the wave sheet.
2. Display the waveform data in tabular view by selecting Tabular from the View menu or click the Tabular View button in the toolbar.
3. Use the mouse to select the tabular data you wish to paste into the spreadsheet applications and select Copy from the Edit menu.
4. Open a spreadsheet application such as Microsoft Excel.
5. Insert the cursor in the spreadsheet file where you want to paste the tabular view and select Paste from the Edit menu.

Creating a Waveform in a Spreadsheet

The software allows you to create a waveform in a spreadsheet application, such as Microsoft Excel, and then load the waveform into your oscilloscope.

To create a waveform in Excel and load it onto your oscilloscope, follow these steps:

1. Acquire a waveform from your oscilloscope using the software.
2. Export the waveform in .CSV or .XLS format from the software.
3. Open the .CSV or .XLS file in Excel.
4. Use the Excel file as a waveform template. Modify the voltage values as needed.
5. Save the Excel waveform file in .CSV format.
6. Import the saved .CSV file into the software.
7. Select Waveform Preamble from the View menu. The Preamble dialog box appears. Adjust the “trigger point” of the new waveform in the pt_o field.
8. Restore the waveform to the oscilloscope using the Restore command under the Instrument menu.

Printing Records

The software allows you to print records up to 500 divisions in length. To print records, follow these steps:

1. Select Properties from the Format menu to open the Graticule Properties dialog box.
2. In the Graticule tab, key in the horizontal divisions to any number up to a maximum of 500 divisions and click OK. The list box settings only go to 20, so you will have to manually key in any setting over 20.
3. Select Print Setup from the File menu to open the Print Setup dialog box. Set Paper Orientation to landscape and click OK.

**NOTE.** Printing records works best if you use a printer that allows banner or continuous printing. Dot matrix printers work best.

4. Select Print from the File menu. Set the print settings and click OK.

The software has a limitation on record length as follows:

Printer Dots Per Inch (DPI) * Graticule size (in inches) \( \leq 32767 \)
Printing Color Waveform Data

If the oscilloscope you are using includes the COLORBMP hardcopy format, you can capture and print pictures in color using a color printer.

To print color waveform data, follow these steps:

1. From your oscilloscope, select either COLORBMP or BMP from the Hardcopy Format Menu. Use COLORBMP for color printing and BMP for monochrome printing.

2. Acquire the picture. See Acquire Picture on page 21 for information on how to capture pictures.

3. Select Print from the File menu. From the Print dialog box click Options... to open the Print Options dialog box.

4. Click OK in the Print dialog box.
Error Messages

This section explains error messages you might see while using WaveStar Software. When possible, procedures for resolving each error are provided.

There are four types of errors:

**GPIB.** Steps to resolve GPIB errors are listed in the *General GPIB Errors* section.

**RS-232.** Steps to resolve RS-232 errors are contained in the *General RS-232 Errors* section.

**Internal.** WaveStar is designed to not display internal error messages. If an internal error message appears, contact Tektronix Technical Support as described on page viii.

**General.** These errors either don’t require extensive resolution procedures or have similar procedures to other errors listed in this section. Procedures for resolving general errors are located in the General and Common Resource Errors section.

If you are unsure as to what type of error you receive, click the Help button in the error message dialog box. This takes you to the corresponding help file for the error message and gives you information on how to resolve the error.
## General GPIB Errors

Table 7 shows most GPIB problems caused by general errors.

### Table 7: General GPIB errors

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Loose cable</td>
<td>Make sure cables are securely connected to both the computer and the oscilloscope.</td>
</tr>
<tr>
<td>Improper cable</td>
<td>Make sure pin numbers and assignments are correct for both the computer and oscilloscope.</td>
</tr>
<tr>
<td>Wrong GPIB address</td>
<td>WaveStar provides addresses 1 through 30. Make sure you have selected the correct address.</td>
</tr>
<tr>
<td>Timeout value too slow</td>
<td>Slower baud rates require very long timeouts. Long timeouts cause long error recoveries, so if you have a problem with the timeout value being too slow, set the timeout value to a faster time.</td>
</tr>
<tr>
<td>Windows GPIB drivers not installed</td>
<td>Install the proper Windows GPIB drivers.</td>
</tr>
<tr>
<td>Old version of GPIB drivers</td>
<td>Upgrade to National Instruments Version 2.7.2 or later.</td>
</tr>
</tbody>
</table>

The following messages are related to the GPIB connection between the computer and the oscilloscope:

- “No GPIB Board Found”
- “Not System Control”
- “Instrument failed to respond to GPIB write. Check instrument address and GPIB cable.”
- “GPIB read error”
- “No Listener on Bus”
- “GPIB Timeout”
- “GPIB Failed”
- “Power On”
If one of the previous messages appears while you are using the software, use the steps below to try to resolve the problem. Most problems have a simple cause such as an incorrect address or faulty cable.

To attempt to correct the GPIB problem, follow these steps:

1. Check that you are using the correct equipment as follows;
   a. National Instruments GPIB Interface card (IEEE Std 488.2) Version C.12 or later
   b. GPIB Cable

2. Disconnect all GPIB cables from computer.

3. Run the hardware diagnostics supplied with the card.

4. Run the software diagnostics supplied with the card.

5. If the GPIB diagnostics fail, or if you have difficulty running them, contact National Instrument Technical Support.

6. If the GPIB diagnostics pass and the software still does not work, contact Tektronix Technical Support as described on page viii.

**General RS-232 Errors**

The following messages are related to the RS-232 connection between the computer and the oscilloscope:

- “Bad RS-232 Port”
- “Bad RS-232 Parameters”
- “Failed to set RS-232 parameters”
- “Failed writing to RS-232 device”
- “Failed to read from RS-232 device”
- “Timeout on RS-232 device”
- “RS-232 owned by another application”
If one of the previous messages appears while you are using the software, use the steps below to try to resolve the problem. Most problems are caused by something simple such as an incorrect COM port or faulty cable.

To attempt to correct the RS-232 problem, follow these steps:

1. Check the baud rate. Use of slow baud rates (such as 300 or 600) is not recommended as they require long timeouts which in turn increases the recovery time from error conditions.

2. Check the type of device. There are two types of RS-232 devices: Data Terminal Equipment (DTE) and Data Communications Equipment (DCE). Most printers, plotters, and computers are DTE devices. Most modems are DCE devices.

3. Check the cable. The user manual for the oscilloscope lists cables that work.
   a. Use a straight-through RS-232 cable when connecting two different types of devices (DTE to DCE).
   b. Use a null-modem cable when connecting similar types of devices (both DTE or both DCE). Null-modem cables enable similar devices to communicate by crossing the send/receive pairs and crossing the handshaking pairs.

Internal Errors

WaveStar is designed not to display internal error messages. Internal errors are errors that occur within the application. If an internal error message is displayed while you are using WaveStar, contact Tektronix Technical Support as described on page viii for help.

General and Common Resource Errors

General and common resource errors are errors that can usually be solved using simple procedures. These are errors not related to the GPIB or RS-232 connection.
Use the following procedures and check to see if the error is corrected. If after using the following procedures and exhausting all other sources of WaveStar help you cannot resolve the error, contact Tektronix Technical Support as described on page viii.

The following messages are related to the general and common resources:

- “Specified Scope does not Match Connected Scope”
- “No Interface or Interface not Set”
- “No Handle Set Up”
- “Can’t Open Driver File”

To attempt to resolve general and common resource errors, follow these steps.

1. Make sure you are not trying to open a file owned by another application.

2. Verify that the oscilloscope you select from the instrument list is the oscilloscope to which your computer is connected.

3. Try closing other windows/applications to free up more memory.

4. Make sure you have either a GPIB or RS-232 connection successfully established between the computer and the oscilloscope.
Appendix A: Menu Commands

This section contains information about menu commands. Selecting a menu command may activate a dialog box. Each dialog box contains a Help button that, when clicked, displays the help for that specific dialog box.

File Menu

The File menu offers the following commands:

New
Use the New command to create a new WaveStar notebook. Each new notebook contains empty wave, picture, settings, and notes sheets.

Open
Use the Open command to open an existing notebook in a new window. You can open multiple notebooks at the same time.

Close
Use the Close command to close the active notebook. If you close a notebook without saving it, you lose all changes made since the last time you saved it. Before closing an untitled notebook, WaveStar displays the Save As dialog box and prompts you to name and save the file before closing the application.

Save
Use the Save command to save the active notebook to its current name and directory. When you save a notebook for the first time, WaveStar displays the Save As dialog box so you can name the notebook and select a directory where the file will be stored. If you want to change the name and directory of an existing document before you save it, choose the Save As command.
Appendix A: Menu Commands

Save As
Use the Save As command to name the active document and choose a directory where the file will be stored. WaveStar displays the Save As dialog box when you save a file for the first time. After you name and save a file, you can use the Save As command to rename the file or select an alternate directory in which to store the file.

Export
The Export command under the File pulldown menu exports the selected waveform from the Wave sheet in either Excel 4 (XLS) format or DocuWave (CSV) format.

This command can also export a picture file from the Picture sheet in a .bmp or a .dib format.

Import
The Import command imports waveform images and settings in TDS waveform (ISF, WFM), 11K series (WFB), or DocuWave (CSV) formats. If you attempt to import a file format other than the DocuWave .CSV format, WaveStar displays the “Improper File Format” error message.

This command can also import a picture file in a .bmp or a .dib format.

Page Setup
Use the Page Setup command under the File menu to set the page size and alignment.

Print
Use the Print command to print a notebook or part of a notebook. What is printed depends on what sheet you select.
### Table 8: Printing results

<table>
<thead>
<tr>
<th>Selected for printing</th>
<th>What gets printed</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wave sheet</td>
<td>Graticule with waveforms</td>
</tr>
<tr>
<td>Wave sheet/tabular view</td>
<td>Waveform data in tabular format; you can also select which pages you want to print.</td>
</tr>
<tr>
<td>Picture sheet</td>
<td>Picture</td>
</tr>
<tr>
<td>Settings sheet</td>
<td>ASCII text settings</td>
</tr>
<tr>
<td>Notes sheet</td>
<td>ASCII text notes</td>
</tr>
</tbody>
</table>

**Print Preview**

The Print Preview command under the File menu activates an on-screen view that previews what the file will look like when printed.

**Print Setup**

The Print Setup command under the File menu activates the Print Setup dialog box. Use Print Setup to select a printer and set all of the printing features before sending a file to the printer.

**<recent file list>**

The recently opened file list contains the last four most recently opened WaveStar files. To open one of the listed files, select it from the numbered list.

**Exit**

Use the Exit command to leave WaveStar. If any open documents have not been saved you will be warned and given the option of saving the file before exiting WaveStar.
Edit Menu

The Edit menu offers the following commands:

**Cut - Ctrl+X**

The Cut command copies the selected item to the clipboard and removes it from its current location.

**Copy - Ctrl+C**

The Copy command copies the selected item to the clipboard.

**Paste - Ctrl+V**

The Paste command pastes the current clipboard item into the current location.

**Cut Wave**

Use the Cut Wave command to cut a waveform from the wave tab and move it to the clipboard. To cut a waveform from the wave tab, select the tab and select Cut Wave from the Edit menu.

**Copy Wave**

Use the Copy Wave command to copy a waveform to the clipboard. To copy a waveform to the clipboard, select the waveform number to the left of the graticule and select Copy Wave from the Edit menu.

**Paste Wave**

Use the Paste Wave command to paste a waveform from the clipboard to a wave tab. To paste a waveform to the graticule, select Paste Wave from the Edit menu. This will paste the waveform from the clipboard into the open notebook.

**Delete Wave**

Use the Delete Wave command to delete a waveform from the graticule. To delete a waveform from the wave tab, select the waveform number to the left of the graticule and select Delete Wave from the Edit menu.
Appendix A: Menu Commands

**Copy Sheet**
Use the Copy Sheet command to copy an entire sheet, or tab, to the clipboard. To copy a sheet to the clipboard, select the tab and select Copy Sheet from the Edit menu.

**Paste Sheet**
Use the Paste Sheet command to paste an entire tab from the clipboard to the open notebook. To paste a tab to the clipboard, select Paste Sheet from the Edit menu. This will paste the tab from the clipboard into the open notebook.

**Delete Sheet**
Use the Delete Sheet command to delete an entire sheet from the notebook. To delete a sheet from the notebook, select the tab and select Delete Sheet from the Edit menu.

**Waveform Preamble**
The Waveform Preamble command brings up the Waveform Preamble dialog box. See *Viewing the Waveform Preamble* on page 23 for further information on this menu command.

For more information on the waveform preamble, refer to the programmer manual for your specific oscilloscope.

**View Menu**
The View menu offers the following commands:

**Waveform YT**
The Waveform YT command displays the graticule in YT view.

**Waveform XY**
The Waveform XY command displays the graticule in XY view.

**Tabular View**
The Tabular command displays the waveform coordinates in table format.
Appendix A: Menu Commands

**Measurements**
The Measurements command displays the waveform measurements.

**Harmonic**
The Harmonic command displays the waveform harmonics.

**Harmonic Tabular**
The Harmonic Tabular command displays the waveform harmonics in tabular format.

**Toolbar**
The Toolbar command toggles the toolbar display.

**Status Bar**
The Status Bar command toggles the Status Bar display. The status bar displays tooltip information and progress information during an application process.

**Zoom**
The Zoom dialog box is activated by selecting the Zoom command.

**Wave Information**
The Wave Information command activates the Waveform Information dialog box which contains information such as scope type, WFID, waveform color and notes, and time and date of acquisition.

**Insert Menu**
The Insert menu offers the following commands:

**Wave**
Select the Wave command to insert a new, empty wave tab in the active file.

**Picture**
Select the Picture command to insert a new, empty picture tab in the active file.
**Settings**
Select the Settings command to insert a new, empty settings tab in the active file.

**Notes**
Select the Notes command to insert a new, empty notes tab in the active file.

**Format Menu**
The Format menu offers the following commands:

**Graticule Properties**
The Graticule command activates the Graticule Properties dialog box which controls Graticule, Plot, Color, and Text properties.

**Picture**
Use the Picture command to format the image on the Picture tab. WaveStar allows you to rotate the picture image with one of four settings: No Rotation, Landscape, 180 degrees rotation, or 270 degrees rotation.

**Instrument Menu**
The Instrument menu offers the following commands:

**Select**
The Select command activates the Select Instrument dialog box. In this dialog box, select the instrument you are using and set either the RS-232 or GPIB connection settings.

**Configure Acquire**
The Configure Acquire command brings up the Configure Acquire dialog box where you set the waveform acquisition settings. Acquire modes include Add and Replace.
Appendix A: Menu Commands

**Acquire**

The Acquire command initiates the acquisition sequence. The actions of the Acquire command depend on the currently selected tab object.

**Table 9: Acquisition results**

<table>
<thead>
<tr>
<th>Selected sheet/tab</th>
<th>Acquisition result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Wave</td>
<td>Actual waveform images from scope</td>
</tr>
<tr>
<td>Picture</td>
<td>Picture image of scope display</td>
</tr>
<tr>
<td>Settings</td>
<td>Scope settings</td>
</tr>
</tbody>
</table>

**Configure Restore**

The Configure Restore command brings up the Configure Restore dialog box where you can set the destination for restored waveforms.

**Window Menu**

The Window menu offers the following commands:

**Cascade**

Use Cascade to arrange multiple opened windows in an overlapped fashion.

**Tile**

Use Tile to arrange multiple opened windows in a non-overlapped fashion.

**Arrange Icons**

Use Arrange Icons to arrange the icons for minimized windows at the bottom of the main window.

<open document list>

The WaveStar software displays a list of currently open document windows at the bottom of the Window menu. A check mark indicates which document is currently in the active window.
Help Menu

The Help menu offers the following commands:

**Contents**
The Contents command activates WaveStar Online Help.

**Search For Help On**
The Search for Help On command activates the WaveStar Online Help search system. This feature allows you to search for help topics by keyword.

**Index**
The Index command activates the WaveStar Online Help index. All WaveStar information is listed in the index alphabetically. Each index entry links to the related help topic in WaveStar Online Help.

**Using Help**
Selecting the Using Help command activates the How to Use Help online help screen. You can also activate the How to Use Online Help screen from WaveStar Online Help by pressing the F1 key.

**Getting Started**
The Getting Started command activates a short tutorial within WaveStar Online Help to help familiarize you with the software.

**Technical Support**
The Technical Support command brings up the help screen explaining the different methods of contacting Tektronix Technical Support.

**About**
The About command activates the About WaveStar dialog box which contains version, copyright, and registration information.
Appendix A: Menu Commands
Appendix B: Dialog Boxes

This section contains information about dialog boxes. Selecting a menu command may activate a dialog box. Dialog boxes in this section are listed in alphabetical order.

Each dialog box contains three common buttons: OK, Cancel, and Help.

- Click OK when you are finished editing dialog box fields and want to apply the new settings.
- Click Cancel to exit the dialog box without making any changes.
- Click Help to bring up the help file corresponding to the current dialog box.

Screen captures of all dialog boxes are available in the Online Help. Click on the Help button in any dialog box to find complete help for the selected dialog box including image-mapped screen captures and descriptions of each field. This section of the manual lists definitions of all dialog fields.

Configure Acquire

Use the Configure Acquire dialog box to set the waveform acquisition parameters.

Export

Use the Export dialog box to select the file format and destination for exported files. The Export dialog box contains the following fields:

File Name. Enter the name of the file to be exported.

Save File as Type. Select either Excel (XLS) or CSV format.

Directories. Select a destination directory for the exported file.

Drives. Select a drive where the destination directory is located.
Appendix B: Dialog Boxes

Format Picture

Use the Format Picture dialog box to set the rotation of the picture image. The Format Picture dialog box contains the following fields:

Normal (no rotation). Sets the picture to the original acquisition position.

Landscape (90 degrees). Rotates the picture image 90 degrees clockwise.

180 degrees. Rotates the picture image 180 degrees clockwise.

270 degrees. Rotates the picture image 270 degrees clockwise.

Graticule Properties

Graticule Tab

Use the Graticule tab in the Graticule Properties dialog box to set the graticule properties. The Graticule tab contains the following fields:

Graticule list box. Select the graticule display type: Full, Grid, Crosshair, or Frame.

Divisions. Set the number of horizontal and vertical divisions for the graticule.

Size/Div. Set the size per division for the graticule.

Plot Tab

Use the Plot tab in the Graticule Properties dialog box to set the plot properties. The Plot tab contains the following fields:

Plot As. Set the plot display to either vectors or dots. Vectors displays a continuous line. Dots displays a series of dots at selected points.

Lock Horizontal Scales. Select the checkbox to lock the horizontal scales on the graticule.

Lock Trigger Points. Select the checkbox to lock the trigger points on the graticule.

Trigger T on Graticule. Select the box to display waveform trigger points on the graticule. Trigger points are displayed as a “T” on the graticule.
**Fast Draw.** Select the checkbox to activate Fast Draw. If you experience a slowing in processing, deselect the checkbox, as Fast Draw requires more system resources.

**Color Tab**

Use the Color Tab to set waveform display, copying, and printing colors. The Color tab contains the following fields:

- **Graticule.** Sets the color of the graticule lines.
- **Readout.** Sets the color of text displayed on the graticule.
- **Background.** Sets the background color of the graticule.

**Default Waveform Color at Acquire.** Sets the default waveform color at acquisition. To set the waveform color after acquisition, use the color selector button in the Waveform Information dialog box.

- **Copy.** Select the color scheme for data copied to the clipboard: color, grayscale, or black lines on white.

- **Print.** Select the color scheme for printed data: color, grayscale, or black lines on white.

**Text Tab**

Use the Text tab to control the display of text on the graticule.

- **Scales.** Select the checkbox to display graticule scales.

- **Cursor Positions.** Select the checkbox to display cursor positions on the graticule.

- **Notes.** Select the checkbox to display the notes on the graticule. Notes displayed on the graticule are notes entered in the Notes field of the Rename Sheet dialog box.

**Import**

Use the Import dialog box to select the file and file format of imported data. The Import dialog box contains the following fields:

- **File Name.** Enter the name of the file to be imported.
Appendix B: Dialog Boxes

**Save File as Type.** Select the file format of the imported data.

**Directories.** Select the directory location of the imported file.

**Drives.** Select the drive where the imported file directory is located.

---

**NOTE.** You can import waveforms only, not pictures.

---

**Open**

Use the Open dialog box to open a saved file. The Open dialog box contains the following fields:

- **File Name.** Name of the file to be opened.
- **List Files as Type.** Choose a file format from the list box. All files in the selected directory that match the file format selected in this field will be displayed in the file list.
- **Directories.** Select directory location of file to open.
- **Drives.** Select drive where directory is located.

---

**Page Setup**

Use the Page Setup dialog box to set the size and alignment of printed data. The Page Setup dialog box contains the following fields:

- **Actual Size.** Displays the data in actual size.
- **Best Fit to Page Size.** Proportionately increases or decreases the image size on the page to best fit the page.
- **Full Page Size.** Increases or decreases the image size to fill the entire page. The image may lose its aspect if you choose this size selection.
- **Center Page.** Centers the image vertically and horizontally on the page.
- **Center Horizontal.** Centers the image horizontally on the page.
Appendix B: Dialog Boxes

Center Vertical. Centers the image vertically on the page.

Print

Use the Print dialog box to set the printing parameters for the open file. The Setup... button brings up the Print Setup dialog box. See the Print Setup dialog box information on page 56 for further information.

The Print dialog box contains the following fields:

Print Range, All. Prints the entire file.
Print Range, Selection. Prints only selected parts of the file.
Print Range, Pages From. Prints the range of pages specified in the From: and To: fields.
Print Quality. Select a printer resolution setting from the list.
Copies. Set the number of copies you want printed.
Collate Copies. Select the checkbox to have the printer collate multiple printed copies.

Print Options

Use the Options... dialog box to set print options. Click the Advanced... button to set advanced printing options. Click the Send Header button to send a header page to the printer.

Print To Printer. Select this field to send print jobs to the printer specified in the Print Setup dialog box.

Print to Encapsulated PostScript File. Select this field to send print jobs to a postscript file. Use the entry field to enter the pathname of the file location to which you want to print.

Margins, Default. Select this field to set page margins to the default printing margins set by the selected printer.

Margins, None. Select the field to print without margins.
Appendix B: Dialog Boxes

**Scaling (%)**. Use this field to set the printing scale. This is the percent scale of the printed data.

**Color Checkbox**. Select this checkbox when using a color printer.

**Send Header with Each Job Checkbox**. Select this checkbox to send a header with each print job.

**Print Setup**

Use the Print Setup dialog box to select a printer, paper size, orientation, and source. Click the Options... button for more printing options.

**Default Printer**. Select Default Printer to use the default printer set in the Windows Print Manager.

**Specific Printer**. Use this field to select a printer other than the Default Printer. A list of available printers is available in the pulldown list.

**Orientation**. Set the paper orientation to either portrait or landscape. This setting applies only to the paper and not to the image display.

**Paper Size**. Select the paper size from the pulldown list.

**Paper Source**. Select the paper source from the pulldown list.

**Rename Sheet**

Use the Rename Sheet dialog box to rename the selected sheet and enter notes. The notes entered in this dialog box are the notes displayed on the graticule. This is the only place you can enter notes to display on the graticule. See Information on Notes on page 13 for more information on the three types of Notes fields in the software.

The Rename Sheet dialog box contains the following fields:

**Tab Text**. Enter the new sheet name in this field.

**Notes**. Use this field to enter notes you want displayed on the graticule. To display the notes on the graticule, open the Graticule Properties Text tab and select the Notes checkbox.
Appendix B: Dialog Boxes

**Restore**

Use the Configure Restore dialog box to set the restore parameters. The Configure Restore dialog box contains the following fields:

*Waveform.* Select the waveform to be restored from the pulldown list.

*<Scope Name>.* The name of this field is the name of the oscilloscope to which you are restoring waveform data. Select the destination oscilloscope from the pulldown list.

**Save / Save As**

Use the File Save As dialog box to either save a new file or to resave a currently saved file to a new filename. The File Save As dialog box contains the following fields:

*File Name.* Enter the name of file to be saved.

*Save File as Type.* Select the file format in which you wish to save the file.

*Directories.* Select the directory location where the file will be saved.

*Drives.* Select the drive where the saved file directory is located.

**Select Instrument**

Use the Select Instrument dialog box to select and set up your oscilloscope for waveform acquisition. The Select Instrument dialog box contains the following fields:

*Scope.* Select your oscilloscope from the oscilloscope list. This list is from the WaveStar driver files. If your oscilloscope is not listed in the oscilloscope list, check to see if the software supports your oscilloscope; then, verify you are using the latest version of WaveStar Software. Upgrades are available from the Tektronix web site at http://www.tek.com/Measurement/Support.

*Interface.* There are two selections in this field: GPIB and RS-232. Which interface is selected depends on what oscilloscope you are using. After selecting your oscilloscope from the list, the software
enables the GPIB or RS-232 fields, or both. See *GPIB Settings Tab* and *RS-232 Settings Tab* for more information.

**Serial Number.** Enter the oscilloscope serial number in this field to automatically enter default instrument settings.

**Defaults.** Click Defaults... to bring up the Instrument Defaults dialog box. Click Use Defaults to use the current instrument settings. Click Change Defaults to save the current settings as the default.

**GPIB Settings Tab**

Use the GPIB Settings tab to set the GPIB interface settings. The GPIB Settings tab contains the following fields:

**Address.** Select the GPIB address from the pulldown list. Addresses range from 1 to 30.

**Timeout.** Use this field to set the timeout rate. Either select one of the preset timeout rates or enter your own value. The timeout rate is the length of time the software will attempt to make a GPIB interface connection. If a connection is not made in the specified timeout time you will get an error message.

**TEST Button.** Click TEST to test your GPIB interface connection.

**Defaults.** Click Defaults... to bring up the Instrument Defaults dialog box. Click Use Defaults to use the current instrument settings. Click Change Defaults to save the current settings as default. Click Factory Settings to use the factory default settings. Factory default settings are located in the driver files.

**RS-232 Settings Tab**

Use the RS-232 Settings tab to set the RS-232 interface settings. Click Custom RS-232 to set custom RS-232 settings. The RS-232 Settings tab contains the following fields:

**Port.** Select the COM port through which you’ll make the connection.

**Baud.** Select the baud rate at which you’ll make the connection.

**Timeout.** Use this field to set the timeout rate. Either select one of the preset timeout rates or enter your own value. The timeout rate is the length of time the software will attempt to make an RS-232 interface connection.
connection. If a connection is not made in the specified timeout time you will get an error message.

**Defaults.** Click Defaults... to bring up the Instrument Defaults dialog box. Click Use Defaults to use the current instrument settings. Click Change Defaults to save the current settings as default. Click Factory Settings to use the factory default settings. Factory default settings are located in the driver files.

**Waveform Preamble**

Use the Waveform Preamble dialog box to set waveform preamble settings. See *Viewing the Waveform Preamble* on page 23 for information on editing the waveform preamble.

The Waveform Preamble dialog box contains the following fields:

**Waveform Names.** Lists names of currently-displayed waveforms. Select a waveform from this list for which you want to view the waveform preamble.

**pt_o.** The pt_o value is the index of the sample following the oscilloscope trigger. In the TDS and THS series oscilloscopes, pt_o is the value of the TDS or THS waveform preamble parameter PT_Off. In the 11000 series oscilloscopes, pt_o comes from dividing the waveform preamble value Xzero by the XINcr value and multiplying by -1:

\[
pt_o = \frac{Xzero}{XINcr} \times (-1)
\]

**xincr.** The xincr value is the value of the waveform preamble value XINcr.

**xzero.** The xzero value in the 11000 series oscilloscopes (DSA60x) is set to the DSA60x waveform preamble parameter TSTime.

**y_off.** In the TDS and THS series oscilloscopes, the y_off value is set to the TDS/THS waveform preamble parameter PT_Off. In the 11000 series oscilloscopes, the y_off value is set to zero.

**ymult.** The ymult value is the value of the waveform preamble parameter YMUlt.
**Appendix B: Dialog Boxes**

**yzero.** The yzero value is the value of the waveform preamble parameter YZero.

**v units.** This field sets the graticule vertical units.

**h units.** This field sets the graticule horizontal units.

### Waveform Information

Use the Waveform Information dialog box to view and edit waveform information. Each waveform has a unique Waveform Information dialog box. See *Viewing and Changing the Waveform Information* on page 28 for more information on editing the Waveform Information dialog box.

The Waveform Information dialog box contains the following fields:

**Scope.** Lists the brand, name, and model number of the oscilloscope used to acquire the selected waveform. You can not edit this field.

**Serial.** Lists the serial number information of the oscilloscope when available. You can enter the serial number of the oscilloscope in the Select Instrument dialog box prior to capturing waveforms.

**WFID.** Waveform ID lists information such as channel, V/div, s/div, number of points, and acquire mode. You can not edit this field.

**Date.** Lists the date the waveform was acquired.

**Time.** Lists the time the waveform was acquired.

**Name.** Lists the waveform name. You can edit this field to change the name of the selected waveform.

**Color.** Click this button to select a new waveform color from the color palette.

**Notes.** Lists waveform notes. You can edit this field to add or change waveform notes. The display of waveform notes is controlled by the Notes checkbox in the Graticule Properties Text dialog box.
Appendix C: RS-232 Interface Reference

Refer to the information in this section regarding RS-232 interface connections for your specific oscilloscope.

Oscilloscope Requirements

This section lists specific requirements for some oscilloscopes when using the RS-232 interface.

11000 Series

If you are using an 11000 series oscilloscope (includes DSA and CSA series), make sure the following are set in the Utility/RS-232 menu:

**Table 10: Utility/RS-232 settings**

<table>
<thead>
<tr>
<th>Field or feature</th>
<th>Set to...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Echo</td>
<td>Off</td>
</tr>
<tr>
<td>Verbose</td>
<td>Off</td>
</tr>
<tr>
<td>Debug</td>
<td>Off</td>
</tr>
<tr>
<td>Delay</td>
<td>Off</td>
</tr>
</tbody>
</table>

Use the Debug facility to see if any characters are being sent from the software to the oscilloscope. To use this facility, go to the Utility/RS-232 menu and toggle the Debug selector to the on position. The top four lines of the instrument display will show any characters which come in over the RS-232 port.

Be sure to set the Debug value to off when you are finished. Software transfers will not work if Debug is set to on.
**TDS 200 or 300 Series**

If you are using a TDS 200 series or TDS 300 series oscilloscope, you can use the Set RS-232 Parameters to Default Values button to set the RS-232 settings on the oscilloscope to the software default values.

Follow the steps below to access the Set RS-232 Parameters to Default Values button:

1. Press the Utility button on your oscilloscope.
2. Push the bottom left bezel button on the oscilloscope repeatedly until I/O is selected.
3. On the oscilloscope push the RS-232C bezel button. The side bezel buttons now control RS-232 settings.
4. To set the RS-232 settings to software default values, push the fourth bezel button.

You can examine the Error Log for clues about your RS-232 interface connection. Follow the steps below to access the Error Log:

1. Push the Utility button on the oscilloscope.
2. Push the bottom left bezel button on the oscilloscope repeatedly until Diag is selected.
3. On the oscilloscope, push the Error Log bezel button.
4. Push the side bezel button labeled Display Log.

Check the lines in the Error Log titled RS-232 Line Snapshot and RS-232 Errors. See your TDS 200 or TDS 300 Programmer Manual for information on interpreting information in the Error Log.

**TDS 400, 500, 600, 700, or 800 Series**

The TDS 400, 500, 600, 700, and 800 series oscilloscopes support RS-232 printers but cannot be controlled over the RS-232 connection. Software can only communicate with these series of oscilloscopes using a GPIB interface connection.
The following reference information applies specifically to the 2221 oscilloscope, but may or may not apply to other 2200 series oscilloscopes.

- Make sure the oscilloscope is in STORE mode and not NON-STORE as selected by the front panel button in the upper right corner of the oscilloscope front panel.

- After changing the dip switch settings on the oscilloscope, you must cycle the power in order for the new settings to take effect.

- Use a baud rate of 2400 or less. The instrument has better performance at 2400 baud than at faster baud rates. Set switches 1 through 4 to 0110 when using a 2400 baud rate.

- Set the parity switch to off (switch 5 = 0).

- Set the EOL switch to CR/LF (switch 8 = 1) and set the software terminator to CRLF in the Custom RS-232 dialog box.

- Switches 6, 7, 9, and 10 can be ignored.

- In the software Custom RS-232 dialog box, set Data Bits to 8, Stop Bits to 1, Parity to None, and make sure software handshaking is not selected.

- In the 2221 oscilloscope Communications menu, set Stop Bits to One and Flow to OFF.

- Make sure you are using the correct port for your cable. The sex of the cable is not necessarily an indication of which port you should be using.

**RS-232 General Hints**

- Make sure the communication parameters are set correctly on both the oscilloscope and software. For oscilloscopes that do not automatically detect some settings, the baud rates should match, the Parity should be set to None, the Data Bits should be set to 8, and the Stop Bits should be set to 1.
For all oscilloscopes, check that the port number matches the port number of the computer to which the oscilloscope is connected and that the period of time for the Timeout parameter matches.

Soft flagging should never be used for waveform and hardcopy transfers. This is because waveform data and hardcopy output contain binary characters which can easily include the XON and XOFF characters used to implement soft flagging. Soft flagging should only be used for transferring stored setups since stored setup information generally consists of printable ASCII text.

- Although it generally shouldn’t matter if the EOL characters are the same, to be sure, set the EOL to CRLF.
- WaveStar usually remembers the settings which were selected the last time the software was used. To force the software to use the default settings each time you open the application, exit the software and delete the WAVESTAR.INI file in the system directory.
- Not all instruments support full RS-232 communications. Some instruments only support GPIB communication, while others support limited RS-232 functions, such as printer functions.
- If you are able to connect to an instrument but unable to transfer waveforms successfully, you may have a cable which is not wired correctly for hard flagging.

If you can successfully transfer settings to and from the instrument at the fastest supported baud rate, hard flagging is probably working. If not, try soft flagging. If you can successfully transfer settings using soft flagging but not with hard flagging, there is a good chance the hard flagging lines of your cable are not connected properly.

- Make sure that the entire setting is restored when you send settings back to the instrument. It is easy for a setting to be only partially restored if hard flagging is not working or if you are not using any flagging. Try using flagging of any kind and use a slow baud rate. If waveform transfers work under these conditions, there is a good chance the hard flagging lines of your cable are not connected properly.
RS-232 Cable Issues

If the information provided so far in this section fails to resolve your RS-232 problems, it may be that you are using an incompatible RS-232 cable. There is no such thing as a standard RS-232 cable, so you may need to use an ohmmeter to verify that your cable is wired correctly. Many cables don’t have all the pins connected.

The first thing you need to know is whether the computer and oscilloscope are DTE (Data Terminal Equipment) or DCE (Data Communications Equipment) devices. This information is in the documentation provided with your oscilloscope and with your computer.

If you are connecting a DTE device to a DCE device you will need a straight-through cable. This is a cable that has the same pin assignments on both ends of the cable.

If you are connecting two devices of the same type, you need a null modem cable. This is a cable whose lines are crossed such that the inputs of one device are connected to the outputs of the other.

**CAUTION. Do not connect the output lines of two same-type devices to each other. Doing so would damage one or both of the devices.**

For hard flagging to work, the RTS (Request To Send) and CTS (Clear To Send) lines must be connected. Use an ohmmeter to verify that they are actually connected since not all cables connect these lines. The RTS line is sometimes referred to as RFR.

The DCD (Data Carrier Detect) line is not used by the software so it does not matter whether or not it is connected. The DCD line is sometimes referred to as RLSD.

RS-232 Cable Examples

The information in this section provides correct wiring and pin assignments for RS-232 interface connections with each type of oscilloscope supported by the software.
11000 Series Oscilloscope to Computer (DB25 male to DB9 female)

Table 11 below lists the correct wiring for connecting an 11000 series (including DSA and CSA series) oscilloscope with 25 pins to a 9 pin serial port on a DTE computer. Tektronix 11000 series instruments are DCE devices.

Table 11: Pin assignments for 11000 series oscilloscope (DB25 to DB9)

<table>
<thead>
<tr>
<th>11000 line</th>
<th>DB25 male pin number</th>
<th>Computer pin number</th>
<th>DB9 female line name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chassis Ground</td>
<td>1</td>
<td>Connector</td>
<td>Chassis Ground</td>
</tr>
<tr>
<td>(TxD)</td>
<td>2</td>
<td>3</td>
<td>(TxD)</td>
</tr>
<tr>
<td>(RxD)</td>
<td>3</td>
<td>2</td>
<td>(RxD)</td>
</tr>
<tr>
<td>(RTS)</td>
<td>4</td>
<td>7</td>
<td>(RTS)</td>
</tr>
<tr>
<td>(CTS)</td>
<td>5</td>
<td>8</td>
<td>(CTS)</td>
</tr>
<tr>
<td>(DSR)</td>
<td>6</td>
<td>6</td>
<td>(DSR)</td>
</tr>
<tr>
<td>(GND)</td>
<td>7</td>
<td>5</td>
<td>(GND)</td>
</tr>
<tr>
<td>(DCD)</td>
<td>8</td>
<td>1</td>
<td>(DCD)</td>
</tr>
<tr>
<td>(DTR)</td>
<td>20</td>
<td>4</td>
<td>(DTR)</td>
</tr>
</tbody>
</table>

11000 Series Oscilloscope to Computer (DB25 female to DB25 male)

Table 12 below lists the correct wiring for connecting an 11000 series (including DSA and CSA series) oscilloscope with 25 pins to a 25 pin
serial port on a computer. Tektronix 11000 series instruments are DCE devices.

Table 12: Pin assignments for 11000 series oscilloscope (DB25 to DB25)

<table>
<thead>
<tr>
<th>11000 line</th>
<th>DB25 male pin number</th>
<th>Computer pin number</th>
<th>DB9 male line name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ground</td>
<td>1</td>
<td>1</td>
<td>Chassis Ground</td>
</tr>
<tr>
<td>(TxD)</td>
<td>2</td>
<td>2</td>
<td>(TxD)</td>
</tr>
<tr>
<td>(RxD)</td>
<td>3</td>
<td>3</td>
<td>(RxD)</td>
</tr>
<tr>
<td>(RTS)</td>
<td>4</td>
<td>4</td>
<td>(RTS)</td>
</tr>
<tr>
<td>(CTS)</td>
<td>5</td>
<td>5</td>
<td>(CTS)</td>
</tr>
<tr>
<td>(DSR)</td>
<td>6</td>
<td>6</td>
<td>(DTR)</td>
</tr>
<tr>
<td>(GND)</td>
<td>7</td>
<td>7</td>
<td>(GND)</td>
</tr>
<tr>
<td>(DCD)</td>
<td>8</td>
<td>20</td>
<td>(DCD)</td>
</tr>
<tr>
<td>(DTR)</td>
<td>20</td>
<td>8</td>
<td>(DSR)</td>
</tr>
</tbody>
</table>

TDS 200 and TDS 300 Series Oscilloscope to Computer (DB9 female to DB9 male)

Table 13 below lists the correct wiring for connecting a TDS 200 series or TDS 300 series oscilloscope with 9 pins to a 9 pin serial port on a DTE computer. TDS 200 series and TDS 300 series instruments are DTE devices.

Table 13: Pin assignments for TDS 200 or TDS 300 series oscilloscope (DB9 to DB9)

<table>
<thead>
<tr>
<th>TDS line</th>
<th>DB9 female pin number</th>
<th>Computer pin number</th>
<th>DB9 female line name</th>
</tr>
</thead>
<tbody>
<tr>
<td>(RxD)</td>
<td>2</td>
<td>3</td>
<td>(TxD)</td>
</tr>
<tr>
<td>(TxD)</td>
<td>3</td>
<td>2</td>
<td>(RxD)</td>
</tr>
</tbody>
</table>
Table 13: Pin assignments for TDS 200 or TDS 300 series oscilloscope (DB9 to DB9) (cont.)

<table>
<thead>
<tr>
<th>TDS line</th>
<th>DB9 female pin number</th>
<th>Computer pin number</th>
<th>DB9 female line name</th>
</tr>
</thead>
<tbody>
<tr>
<td>(DTR)</td>
<td>4</td>
<td>6</td>
<td>(DSR)</td>
</tr>
<tr>
<td>(GND)</td>
<td>5</td>
<td>5</td>
<td>(GND)</td>
</tr>
<tr>
<td>(DSR)</td>
<td>6</td>
<td>4</td>
<td>(DTR)</td>
</tr>
<tr>
<td>(RTS)</td>
<td>7</td>
<td>1, 8(^1)</td>
<td>(CTS)</td>
</tr>
<tr>
<td>(CTS)</td>
<td>8</td>
<td>7</td>
<td>(RTS)</td>
</tr>
</tbody>
</table>

\(^1\) Pins 1 and 8 are wired together.

Connecting Two Like Devices Using a Null-Modem Cable

Table 14 below lists the correct wiring for connecting two like devices together using a 25-pin DB25 female to 25-pin DB25 female cable.

Table 14: Pin assignments for DB25 female-to-female null-modem cable

<table>
<thead>
<tr>
<th>DB25 connector</th>
<th>Pin number</th>
<th>Computer pin number</th>
<th>Line name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chassis Ground</td>
<td>1</td>
<td>1</td>
<td>Chassis Ground</td>
</tr>
<tr>
<td>(TxD)</td>
<td>2</td>
<td>3</td>
<td>(RxD)</td>
</tr>
<tr>
<td>(RxD)</td>
<td>3</td>
<td>2</td>
<td>(TxD)</td>
</tr>
<tr>
<td>(RTS)</td>
<td>4</td>
<td>5</td>
<td>(CTS)</td>
</tr>
<tr>
<td>(CTS)</td>
<td>5</td>
<td>4</td>
<td>(RTS)</td>
</tr>
<tr>
<td>(DSR DCD)</td>
<td>6, 8(^1)</td>
<td>20</td>
<td>(DTR)</td>
</tr>
<tr>
<td>(DTR)</td>
<td>20</td>
<td>6, 8(^1)</td>
<td>(DCR DCD)</td>
</tr>
<tr>
<td>(Signal GND)</td>
<td>7</td>
<td>7</td>
<td>(Signal GND)</td>
</tr>
</tbody>
</table>

\(^1\) Pins 6 and 8 are wired together.
Index

A

Acquire command, 48
acquisition results, 48
ALT button combinations, 14
applications, 29

B

baud rate, 19

C

common resource errors, 38
resolving, 39
compatible oscilloscopes, 1
Configure Acquire, 47
Configure Restore, 48
connection procedures
  GPIB communication interface, 17
  RS-232 communication interface, 19
contacting Tektronix, viii
conventions, vii
copy
  graticule to clipboard, 29
  notes to clipboard, 30
  picture to clipboard, 30
  settings to clipboard, 31
creating waveforms, using Excel, 32
cursor positions, dX, dY, X, Y, 10

D

Data Communications Equipment, 38
Data Terminal Equipment, 38
DocuWave software, upgrading to
  WaveStar Software, 2
dX, cursor position, 10
dY, cursor position, 10

E

Edit menu, 44
  Copy, 44
  Copy Sheet, 45
  Copy Wave, 44
  Cut, 44
  Cut Wave, 44
  Delete Sheet, 45
  Delete Wave, 44
  Paste, 44
  Paste sheet, 45
  Paste Wave, 44
  Waveform Preamble, 45
Error messages, 35
  general, 35
  GPIB, 35
  internal, 35
  RS-232, 35
Exit, Print Preview, 43
export, file formats allowed, 28
Index

F

File menu, 41
  Close, 41
  Export, 42
  Import, 42
  New, 41
  Open, 41
  Page Setup, 42
  Print, 42
  Print Preview, 43
  Print Setup, 43
  Recent file list, 43
  Save, 41
  Save As, 42
Format menu, 47
  Graticule, 47
  Picture, 47

G

general errors, 35, 38
  resolving, 39
GPiB communication interface
  connecting to an oscilloscope, 17
  required equipment, 17
  resolving problems, 18
GPiB errors, 35, 36
  common errors, 36
  resolving, 37
graticule
  copying to clipboard, 29
  waveform display, 10

H

h units, 60
hardcopy picture, 12
harmonic measurement, 26
  Graph view, 26
  Tabular view, 26
Help button, 14
Help menu, 15, 49
  About, 49
  Contents, 49
  contents, 15
  Getting Started, 49
  getting started, 15
  Index, 49
  index, 15
  Search for Help On..., 15, 49
  technical support, 49
  Using Help, 49
  using Help, 15
horizontal position button, 11
horizontal scale, 10

import, file formats allowed, 27
Insert menu, 46
  Notes, 47
  Picture, 46
  Settings, 47
  Wave, 46
installation, 3
  File Manager, 4
  Program Manager, 3
  System files, 5
  Windows 95, 4
Instrument menu, 47
  Acquire, 48
  Configure Acquire, 47
  Configure Restore, 48
  Select, 47
internal errors, 35, 38
Index

L
list box
cursor type, 10
harmonic measurements, 26
waveforms, 11

M
Main screen, 9
measurements
creating power waveforms, 27
current, 29
harmonic, 26
power, 29
time, 29
viewing waveforms, 23
voltage, 29
Menu bar, 9, 14
using keyboard, 14
using mouse, 14

N
note information
copying to clipboard, 30
displayed on the graticule, 13
Notes Sheet, 13
Rename Sheet dialog box, 13
types, 13
Waveform Information dialog box, 13
Notes sheet, 13
NT operating system, WSTROU software, 2
null-modem cable, 38

O
Online Help, 14

operating basics, 9
oscilloscopes, compatible, 1

P
paste, spreadsheet data into tabular view, 31
Picture sheet, 12
pictures
acquiring from oscilloscope, 21
copying to clipboard, 30
exporting, 28
importing, 27
port, 19
position, waveforms
horizontal, 11
vertical, 10
power analysis, 27
pt_o, 59

R
Rename Sheet dialog box, 13
requirements, 1
restoring data
settings, 21
waveforms, 21
restrictions, 1
RS-232 communication interface
connecting to an oscilloscope, 19
required equipment, 19
RS-232 errors, 35, 37
Data Communications Equipment, 38
Data Terminal Equipment, 38
null-modem cable, 38
resolving, 38
slow baud rate, 38
straight-through cable, 38
Index

S

scale, waveforms
  horizontal, 10
  vertical, 10
scrolling through sheets, 12
Select Instrument, 47
settings
  copying to clipboard, 31
  restoring to oscilloscope, 21
Settings sheet, 12
sheet position buttons, 12
slow baud rate, RS-232, 38
spreadsheet
  creating waveforms, 32
  pasting into tabular view, 31
straight-through cable, 38
system files, installed, 5

T

Tabular view, 45
  pasting into a spreadsheet, 32
  viewing waveforms, 22
technical support, viii
terms used in this manual, vii
TEST button, 20
timeout, 19
Tool bar, 9
trigger point, 10

U

uninstall, 6
  Automatic, 6
  Custom, 6
files to remove
  data, 7
  directories, 7
  for consideration, 6
icons, 7
system, 7
system files, do not delete, 4
upgrades, 2

V

v units, 60
vertical position button, 10
vertical scale, 10
View menu, 45
  Harmonic, 46
  Harmonic Tabular, 46
  Measurements, 46
  Status Bar, 46
  Tabular view, 45
  Toolbar, 46
  Wave Information, 46
  Waveform XY, 45
  Waveform YT, 45
  Zoom, 46
viewing, waveform
  harmonics, 26
  measurements, 23
  preamble, 23
viewing, waveform, data, 22

W

Wave sheet, 9
waveform data
  capturing
    oscilloscope, 20
    pictures, 21
settings, 20
  restoring to, oscilloscope, 21
Waveform Information
  changing, 28
dialog box, 13
Waveform list box, 11
selection button, 11
Waveform Preamble, 23, 45
h units, 60
pt_o, 59
v units, 60
xincr, 59
xzero, 59
y_off, 59
ymult, 59
yzero, 60
waveforms
acquire, 48
color on the display, 28
displayed on graticule, 10
exporting, 28
importing, 27
number, 10
power analysis, 27
restoring to oscilloscope, 21
selection buttons, 11
selection list, 11
viewing, 22
Harmonic Graph view, 26
Harmonic Tabular view, 26
measurements, 23
preamble, 23
Tabular view, 22
Waveform Information dialog box, 28
XY view, 22
YT view, 22
WaveStar software, starting, 5
Window menu, 48
Arrange Icons, 48
Cascade, 48
Open document list, 48
Tile, 48
Windows 98 operating system,
WSTROU software, 2
WSTR31U DocuWave upgrade, 2
WSTROU software
NT operating system, 2
Windows 98 operating system, 2

X
X, cursor position, 10
xincr, 59
xzero, 59

Y
Y, cursor position, 10
y_off, 59
ymult, 59
yzero, 60